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Introduction 
Welcome to the Rocket PASSPORT FTP Client - User's Guide. This guide provides operation instructions 
and technical reference for the use of the Rocket PASSPORT FTP Client. 

PASSPORT FTP Client is a robust, full-featured FTP client that provides fast file transfer between a host 
system and a client. The PASSPORT FTP Client is launched from within the PASSPORT terminal emulation 
program using the Transfer > FTP menu command. The PASSPORT FTP Client also features SSL (FTPS) 
and SSH (SFTP) secure file transfer. 

FTPS provides a secure file transfer through the use of the SSL layer, found below the standard FTP 
protocol, and encrypts the control and/or data channels. PASSPORT FTP implements FTPS according to 
IETF RFC 4217 Securing FTP with TLS. The PASSPORT FTP Client connects to a standard FTP server port 
21 and begins an unencrypted FTP session as it normally would, then requests that SSL security be used 
through the AUTH TLS command and performs the necessary SSL handshaking. 

PASSPORT FTP Client also supports SSH File Transfer (SFTP). SFTP relies on the SSH protocol to provide 
secure file transfer. The PASSPORT SFTP is based on the PuTTY SSH implementation for Win 32. 

The PASSPORT FTP Client fully adheres to the IETF RFC 959 File Transfer Protocol specification. The FTP 
Client uses an asynchronous interface to the Windows sockets TCP/IP driver providing the fastest file 
transfer data rate possible while using a minimal amount of system resources.  

The FTP Client features the look and feel of Windows Explorer: 

• Menu bar, toolbar and status bar 

• Window panes for PC directory structure and file list 

• Window panes for Host directory structure and file list 

• Window pane for connection log and error messages 

• All window panes can be interactively resized  

Multiple host profiles can be created and easily selected as needed (PC TO HOST only).  

Send and Receive File Transfer can be initiated by the following: 

• Drag and drop from one window pane to another window pane 

• Transfer>Send and Transfer>Receive menu commands 

• Cut, Copy, and Paste using Edit menu commands 

• Cut, Copy, and Paste using Ctrl+X, Ctrl+C, and Ctrl+V short-cut keys 

• Cut, Copy, and Paste using right mouse button and floating menu bar  

Files displayed in the PC and Host window panes can be displayed several ways: 

• Large icons 
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• Small icons 

• List 

• Detail  

Files and icons can be sorted by: 

• Size 

• Date 

• Type 

• Permission 

• Owner 

• Group 

• Automatically arranged 
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Using FTP Client 
Adding a Host Profile 
Before you can use FTP to connect to a host computer, you must provide information about that host by 
creating a profile. 

To add a host to your current configuration: 

1. Choose the Communication>Setup menu command. 

2. Choose the Add button to display the Add FTP Host dialog box. 

3. Enter a name for the host that is meaningful to you. 

4. Click OK. The Communication Setup dialog box appears (if it is not already displayed) with the 
host profile name added to the list. 

5. Click the Settings tab. 

6. Enter your email address in the field provided. 
 
Note: If you do not enter an email address on the Settings tab, you will have to enter your email 
address manually in the Password field on the Profiles tab if you select the Anonymous option 
(step 8). 

7. Click the Profiles tab. 

8. Enter information to define the FTP host. See Communication Setup for specific information on 
the fields and buttons of this dialog box. 

9. Click OK to add the host to the Profile, Cancel if you have decided not to add this host to the list 
or Connect to test the host connection. 

  

Error Response from Host 
A negative response from the host can result when the host file name does not have the correct syntax 
for the host operating system you are transferring a file to. For the following IBM host operating 
systems, make sure the host file name syntax is correct: 

VM Operating System 

<filename> <filetype> <filemode> 

For the VM operating system, file names consist of three parts. Each part is separated by a space. 

<filename> is 1 to 8 characters in length. 
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<filetype> is 1 to 8 characters in length. 

<filemode> is 1 alphabetic character followed by an optional numeric character.  

Examples: 

Profile exec a1 

Readme data a2  

MVS and OS/390 Operating Systems 

There are two types of files: sequential and partitioned datasets. A partitioned dataset is more like a PC 
directory that contains many member files inside of it. A sequential dataset is more like a regular PC file. 

Sequential datasets: 

[‘<high level qualifier>.]<qualifier>.<qualifier>…[‘] 

The sequential dataset file name can consist of many qualifiers separated by the period ‘.’ character. 
Each <qualifier> must be 1 to 8 characters in length and must begin with an alphabetic character. If the 
<high level qualifier> is used, the entire file name must be enclosed in single quotes. If the file name is 
not enclosed in quotes, the default <high level qualifier> is attached to beginning of the file name. The 
default <high level qualifier> is typically the logon user ID.  

Examples: 

‘P390A.ZEPHYR.DATA’ 

ZEPHYR.DATA 

‘SYS1.VTAM.DATA.LIST’  

Partitioned datasets: 

[‘<high level qualifier>.]<qualifier>.<qualifier>(<member>)[‘] 

The partitioned dataset consists of qualifiers similar to the sequential dataset. The <member> items are 
files that are contained inside the partitioned dataset. Each <qualifier> and <member> must be 1 to 8 
characters and must begin with an alphabetic character.  

Examples: 

‘P390A.DATA.FILES(FILE1)’ 

‘P390A.DATA.FILES(FILE2)’ 

DATA.FILES(FILE3) 

  

File Transfer Status Dialog 
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When one or more files are in the process of transferring, the File Transfer Status dialog box will display 
with the following information: 

Sending/Receiving 
The dialog box title bar will display Sending or Receiving to indicate the direction of the current file 
transfer. 

Host file name 
Indicates the current host file. If multiple files are being transferred, this will change when one file 
transfer is completed and another starts. 

PC file name 
Indicates the current PC file. If multiple files are being transferred, this will change when one file transfer 
is completed and another starts. 

Transferred 
The following information is displayed regarding the file in progress: 

• Bytes transferred 

• Percentage of transfer completed 

• Transfer rate in Kilobytes per second (KBps) 

• Time elapsed in HH:MM:SS format 

• Time remaining in HH:MM:SS format 

File Size & Type 
Indicates the total size and file format (ASCII or Binary) of the current file. 

Number of Files Transferred 
For multiple file transfers, indicates how many files have completed successfully. 

Total Bytes Transferred 
Indicates in Bytes the total amount of data that has been transferred. 

Abort 
While a file transfer is in progress the Abort button is available to cancel the operation. This does not 
affect files that have already successfully transferred but will prevent any remaining files from 
transferring. 

Finish 
If the Close File Transfer Status Dialog On Completion option is disabled on the Settings tab of 
Communication>Setup then the Finish button must be pressed to close the dialog and return to the 
PASSPORT FTP Client. 

  

FTP Toolbar 
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Click ...   To do this ... 

 

Change Local Path Changes directory for the local PC files 

 

Change Host Path Changes directory for the remote host files 

 

New Folder Create a new folder at remote host or local PC 

 

Delete Delete files and directories at remote host or local PC 

 

View File Open the selected file 

 

Properties View the properties of the currently selected file 

 

Cut Cut the selection and place it in the Windows Clipboard 

 

Copy Copy the selection and place it in the Windows Clipboard 

 

Paste Insert Clipboard contents 

 

Connect Connect to FTP server 

 

Disconnect Disconnect from FTP server 

 

Cancel Cancel pending command 

 

Send to Host Transfer selected file(s) from PC to host 

 

Receive from Host Transfer selected file(s) from host to PC 

 

ASCII Set transfer mode to ASCII 

 

Binary Set transfer mode to Binary 

 

Auto Set transfer mode to Auto 

 

Large Icons Display items by using large icons 

 

Small Icons Display items by using small icons 

 

List Display items in a list 

 

Details Display information about each item in the window 

 

Help Topics List Help topics 

 

About Display program information, version number and copyright 
  

  

Main Window 
Launching FTP displays the PASSPORT FTP Client window. This window is similar in look and 
functionality to those in other Windows-based applications.  

The top portion contains the typical Windows items: title bar, menus, and toolbar. Directly below these, 
the majority of the window area is divided into three horizontal sections. (These sections may be resized 
by placing the cursor directly on the horizontal line and then clicking and dragging.) 

1. The first section is devoted to your local computer. This section is a replication of what you see 
in your Windows Explorer. On the left is the directory “tree” or hierarchy of drives and folders 
located on your PC. Clicking a drive or folder on the left side displays its contents to the right. 
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2. The second horizontal section is concerned with those areas of the host computer that you can 
access. Again, the host directory “tree” or hierarchy of folders appears on the left. Clicking a 
drive or folder on the left displays its contents to the right. 

3. The third horizontal section displays the FTP log. When you connect to the host and send or 
receive files, a list of process activities appear here. These also appear in the Connection Log.  

At the bottom of the PASSPORT FTP Client window is a status bar for providing information about the 
current activity, such as the status of the host connection or the size of the file being transferred. 

Once the PASSPORT FTP Client window is displayed, you are ready to create host profiles and to start an 
FTP session. 

  

Receiving Files 
Once you are connected to the host computer (see Starting an FTP Session), you are ready to transfer 
files from the host to your local computer. 

To Receive Files: 

1. Locate and select a directory on your PC as the destination for the item(s) you want to transfer 
from the host. 

2. Locate and select from the host directory the item(s) you want to transfer to your PC. 

3. Choose the Transfer>Receive menu command or click the Receive button on the toolbar. You 
can track the progress of the transfer in the FTP Log section of the window. 
 
Note: Any difference noted between the size of the file in its original location and its size in the 
new location is the result of different disk formatting protocols. If the file being transferred 
already exists on your PC, a dialog box warns you, allowing you to decide if you want to replace 
the old with the new. 

4. Continue to send and receive files until you are ready to disconnect from the host. 

5. To disconnect, choose the Communication>Disconnect menu command or click the Disconnect 
button on the toolbar. 

  

Sending Files 
Once you are connected to the host computer (see Starting an FTP Session), you are ready to transfer 
files from your local computer to the host. 

To Send Files: 

1. Locate and select a host directory as the destination for the item(s) you want to transfer from 
your PC to the host. 
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2. Locate and select from you PC directory the items(s) you want to transfer to the host. 

3. Choose the Transfer>Send menu command or click the Send button on the toolbar. You can 
track the progress of the transfer in the FTP Log section of the window. 
 
Note: Any difference noted between the size of the file in its original location and its size in the 
new location is the result of different disk formatting protocols. 

4. Continue to send and receive files until you are ready to disconnect from the host. 

5. To disconnect from the host, choose the Communication>Disconnect menu command or click 
the Disconnect button on the toolbar. 

  

Starting an FTP Session 
Once you have created a host profile (see Adding a Host Profile), you are ready to connect to the host 
computer. 

To start an FTP session: 

1. Choose the Communication>Connect menu command or click the Connect button on the 
toolbar. The Communication Setup dialog box appears listing available host profiles. 

2. Select from the list of hosts the one to which you want to connect. 
 
Note: If the desired profile is not on the list, you may add it by clicking the Add button. 

3. Click the Connect button. When the connection is complete, the host directory structure 
appears.  

Note: The status bar provides information on the progress of the connection to the host. This 
information is also available by choosing the Communication>Connection Log menu command. The log 
retains the host information until you quit the application. 
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Menu Commands 
File 

File > New 
The File > New menu command provides three options: 

1. File > New > Configuration (PC TO HOST only) 

2. File > New > Folder 

3. File > New > FTP Site 

4. File > New > Window 

The File > New > Configuration option allows you to create a new custom configuration file. Multiple 
configuration files may be stored on the workstation, each having it's own individual setting. This menu 
command function can be duplicated by the following: 

Ctrl + N key sequence 

The File > New > Folder option allows you to create a new folder in a location you have chosen on your 
local computer or the remote host computer. This menu command function can be duplicated by the 
following: 

• toolbar button 

• Alt + F, N, F key sequence  

The File > New > FTP Site option allows you to add a new FTP host. (See Adding a Host Profile for a step-
by-step guide to doing this.) This menu command function can be duplicated by the following: 

• Alt + F, N, S key sequence  

The File > New > Window option opens a new FTP window with default parameters. This menu 
command function can be duplicated by the following: 

• Alt + F, N, W key sequence 

  

File > Open 
The File > Open menu command displays the Open dialog box, allowing you to open a configuration file 
other than the default (PASSPORT.zft). Select the appropriate PASSPORT FTP Client configuration file 
from the list then click OK. 

The File > Open command function can be duplicated by the following: 
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• Ctrl + O 

Note: the file menu also maintains a list of the most commonly used configuration files for quick access. 
The last four configuration files used are kept in this list and may be opened directly from the File menu. 

  

File > Save 
The File > Save menu command saves any changes made to the current configuration file. 

The File > Save command function can be duplicated by the following: 

• Ctrl + S 

  

File > Save As 
The File > Save As menu command displays the Save As dialog box, allowing you to save the current 
configuration as a new file or overwrite an existing one. 

  

File > Change Local Path 
The File > Change Local Path menu command allows you to change the directory on your local 
computer. A dialog box appears with a text entry box for you to type in the local path or directory that 
you wish to navigate to. The OK button performs the operation and highlights the selected local path in 
the PC directory pane. The Cancel button simply cancels the operation. 

The File > Change Local Path command function can be accessed by the following: 

• toolbar button 

• Alt + F, L key sequence 

• F3 short cut key 

  

File > Change Host Path 
The File > Change Host Path menu command allows you to change the directory on your remote host 
computer. A dialog box appears with a text entry box for you to type in the host path or directory that 
you wish to navigate to. The OK button performs the operation and highlights the selected local path in 
the PC directory pane. The Cancel button simply cancels the operation. 

The File > Change Host Path command function can be duplicated by the following: 

• toolbar button 
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• Alt + F, H key sequence 

• F4 short cut key 

  

File > Delete 
The File > Delete menu command allows you to delete selected folders or files on your local computer 
or the remote host computer. A dialog box gives you the opportunity to confirm the deletion (click the 
OK button) or to change your mind (click the Cancel button). 

The File > Delete command function can be duplicated by the following: 

• toolbar button 

• Right-click, then click Delete 

• Alt + F, D key sequence 

  

File > Rename 

The File > Rename menu command allows you to rename a selected folder or file on your local 
computer or the remote host computer. 

The File > Rename command function can be duplicated by the following: 

• Right-click, then click Rename 

• Alt + F, R key sequence 

  

File > View File 
The File > View File menu command opens the currently selected file on your local computer or the 
remote host computer using the associated application. If no application is associated with the file, then 
the application specified in the Default Viewer field of the Settings Tab in Communication Setup will be 
used to open the file. 

  

File > Properties 
The File > Properties menu command opens the Properties dialog box containing information about the 
file or folder currently selected in your local computer or the remote host computer. This dialog box 
provides information that is found in a standard properties dialog box associated with the Windows 
Explorer for the local file or folder. For a file or folder located or the remote host computer, the dialog 
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box provides basic information about the file, such as size, date, and permissions. The information that 
is displayed for a remote file or folder will depend on the host FTP server. 

The File > Properties command function can be duplicated by the following: 

• Place cursor on file or folder, right-click, then click Properties 

• Alt + F, P key sequence 

  

File > Exit 
The File > Exit menu command closes and exits the FTP application. 

The File > Exit command function can be duplicated by the following: 

• Alt + F, X key sequence 

  

File > Exit All 
The File > Exit All menu command closes and exits all the FTP sessions currently open, both active and 
not active. 

The File > Exit All command function can be duplicated by the following: 

• Alt + F, E key sequence 

  

Edit 

Edit > Cut 
The Edit > Cut menu command cuts the selection and places it on the clipboard. 

Note: This command only applies to files located on the local PC. 

The Edit > Cut command function can be duplicated by the following: 

• toolbar button 

• Right-click, then click Cut 

• Alt + E, T key sequence 

• Ctrl + X short cut key 
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Edit > Copy 
The Edit > Copy menu command copies the selection and places it on the Clipboard. 

The Edit > Copy command function can be duplicated by the following: 

• toolbar button 

• Right-click, then click Copy 

• Alt + E, C key sequence 

• Ctrl + C short cut key 

  

Edit > Paste 
The Edit > Paste menu command inserts the contents of the Clipboard in the selected location. 

The Edit > Paste command function can be duplicated by the following: 

• toolbar button 

• Alt + E, P key sequence 

• Ctrl + V short cut key 

  

Edit > Select All 
The Edit > Select All menu command selects the contents (that appear on the right) of the drive or 
directory folder selected on the left. 

The Edit > Select All command function can be duplicated by the following: 

• Alt + E, A key sequence 

• Ctrl + A 

Note: The automatic copying of text only works when text is selected with the mouse, and not the 
keyboard, therefore Automatic Copy of Selected Area is not available in conjunction with the "Select All" 
feature. 

  

Edit > Invert Selection 
The Edit > Invert Selection menu command reverses which content items on the right are selected and 
which ones are not. 
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The Edit > Invert Selection command function can be duplicated by the following: 

• Alt + E, I key sequence 

  

View 

View > Toolbar 
The View > Toolbar menu command makes the toolbar either visible or not visible. A check mark next to 
the Toolbar menu item indicates that the toolbar is visible. This setting is saved in the session profile. 

The View > Toolbar menu command function can be duplicated by the following: 

• Alt + V, T key sequence 

  

View > Status Bar 
The View > Status Bar menu command makes the status bar either visible or not visible. A check mark 
next to the Status Bar menu item indicates that the status bar is visible. This setting is saved in the 
session profile. 

The View > Status Bar menu command function can be duplicated by the following: 

• Alt + V, S key sequence 

  

View > Connection Log 

The View > Connection Log menu command makes the connection log pane at the bottom of the 
window either visible or not visible. A check mark next to the Connection Log menu item indicates that 
the connection log pane is visible. This setting is saved in the session profile. 

The View > Connection Log menu command function can also be accessed by: 

• Alt + V, C key sequence 

  

View > Large Icons 
The View > Large Icons menu command displays as large icons the folders and files in the current 
directory item on both your local computer and the host. 

The View > Large Icons command function can be duplicated by the following: 

• toolbar button 
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• Alt + V, G key sequence 

  

View > Small Icons 
The View > Small Icons menu command displays as small icons the folders and files in the current 
directory item on both your local computer and the host. 

The View > Small Icons command function can be duplicated by the following: 

• toolbar button 

• Alt + V, M key sequence 

  

View > List 
The View > List menu command displays as a list the folders and files in the current directory on both 
your local computer and the host. 

The View > List command function can be duplicated by the following: 

• toolbar button 

• Alt + V, L key sequence 

  

View > Details 
The View > Details menu command displays the details about each folder and file in the current 
directory. On the local computer, the available details are Name, Size, Type, and date Modified. On the 
host the available details are Name, Size, date Modified, Permissions, Owner, and Group. 

The View > Details command function can be duplicated by the following: 

• toolbar button 

• Alt + V, D key sequence 

  

View > Arrange Icons 
The View > Arrange Icons menu command provides you with eight choices of ways to arrange the 
contents icons in the current drive or folder on both your local computer and the host. 

The View > Arrange Icons command can be duplicated by the following: 
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Arrange By Key Sequence 
Name Alt + V, I, N 
Size Alt + V, I, S 
Date Alt + V, I, D 
Type Alt + V, I, T 
Permissions Alt + V, I, P 
Owner Alt + V, I, O 
Group Alt + V, I, G 
Auto Arrange Alt + V, I, A 
  

  

View > Refresh 
The View > Refresh menu command allows you to update your directory display to incorporate any 
modifications made since you booted your local computer or connected to the host. 

The View > Refresh command function can be duplicated by the following: 

• Alt + V, R key sequence 

• F5 short cut key 

  

Communication 

Communication Setup 

Communication > Setup 

The Communication > Setup menu command displays the Communication Setup dialog box, allowing 
you to add or remove host profiles available for an FTP session. 

The Communication > Setup property sheet page has five pages that can be configured: 

• Profiles 

• Firewall 

• Settings   

• SSH 

• SSL 

The Communication > Setup command function can be duplicated by the following: 
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• Alt + C, S key sequence 

  

Profiles Tab 

The Profiles tab is the default tab in the Communication Setup property sheet. 

Profile List 
An alphabetical list of the profiles already existing in the current configuration file.    

Add 
The Add button displays the Add FTP Host dialog box for creating a new profile. In the Profile Name 
field, enter a name for the host that is meaningful to you and click OK. 

Edit 
The Edit button displays the Add FTP Host dialog box with the name of the selected host profile 
appearing in the Profile Name field for change.    

Remove 
The Remove button deletes the selected host profile from the list.    

Server Type 
Select the server type from the drop down. You may select either FTP, SFTP using SSH, or FTP over SSL. 

Host Name 
Enter the name of the host computer. You may use the URL format or the actual IP address. IPv4 and 
IPv6 are both supported. 

Host Type 
Choose from the list of available host types or select Auto Detect to allow the FTP Client to determine 
what type of host it is connecting to. Sometimes, you will need to choose a specific host type instead of 
Auto Detect, because different FTP servers list directories differently.    

FTP Port 
The standard port setting of 21 is entered as a default for FTP and FTPS. The default port for SFTP is 22. 
However, you may enter a different port.    

Anonymous 
Click this check box if you do not have a user name and password on the host and the host allows you to 
enter anonymously. The system automatically enters “anonymous” as the Username and your email 
address as the Password.    

Username 
Enter your user name on the host computer. If you are accessing a public FTP server that does not have 
user name or password restrictions, click the Anonymous check box.   

Password 
Enter your password on the host computer.    



PASSPORT FTP User's Guide 

18 

Save Password 
Checking this box will encrypt your password and save it in the current configuration file so that you do 
not have to reenter it each time you connect to the host. 

Account 
Enter the account name on the host computer if one is required. Some hosts require an account name in 
addition to user name and password. 

Timeout (sec) 
Enter the number of seconds during which FTP will try to make connection to the host computer before 
quitting. The default value is 60 seconds.    

Retry 
Enter the number of times FTP is to try to connect to the host computer after timing out because a 
connection was not made. The default value is 10 times.    

Initial Path 
Enter the name of a host directory that you want as the default directory when connecting to the host. 
This field is optional.    

Use PASV Transfer Mode (FTP and FTPS only) 
Click this option to indicate that you want to use the passive data transfer mode to initiate the transfer 
instead of the active mode. In active mode, the FTP client opens a random port, sends the FTP server the 
random port number on which it is listening over the control channel, and waits for a connection from 
the FTP server. In passive mode, the FTP server opens a random port, sends the FTP client the server's IP 
address to connect to and the port on which it is listening over the control channel, and waits for a 
connection from the FTP client. This setting is recommended if data is to be transferred through a 
firewall. 

Note: If server sends an unroutable address in the PASV reply, Passport will use the server 
address instead. 

Local PC Initial Directory 
Enter the name of a directory on your local computer that you want as the default directory when 
connecting to a specific host computer. This ensures that any transfers are from or into this specific local 
directory which you have selected for that purpose. A Browse button allows you to search for the 
desired directory. This field is optional.    

OK 
The OK button is available only if you opened the Communication Setup dialog box using the 
Communication>Setup menu command. Clicking this button saves the host profile information you have 
entered, adds the profile to the list using the name you have entered in the Profile Name field of the 
Add FTP Host dialog box, and closes the Communication Setup dialog box.    

Connect 
The Connect button is enabled only if there is no active FTP connection. This Connect button has two 
functions: 

1. When you select a host profile from the list, clicking this button starts the connection process. 
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2. When you add a new host profile, clicking this button adds the new profile to the list and also 
starts the connection process.    

Cancel 
The Cancel button discards any entries you have made on any of the three tabs and closes the 
Communication Setup dialog box.    

Help 
The Help button displays this help screen. 

  

Firewall Tab 

The Firewall tab is one of the tabs in the Communication Setup property sheet. This tab enables you to 
enter information about the firewall through which you are communicating. 

Use Firewall 
Select this check box to enable the following fields for entering information about the firewall.  

Type 
Select the type of firewall from the drop-down list. "SITE hostname" is the default.  

Host Name 
Enter the name of the firewall.  

Port 
Enter the port number for the firewall.  

Username 
Enter your user name to gain access through the firewall.  

Password 
Enter your password on the firewall.  

OK 
The OK button is available only if you opened the Communication Setup dialog box using the 
Communication>Setup menu command. Clicking this button saves the host profile information you have 
entered, adds the profile to the list using the name you have entered in the Profile Name field of the 
Add FTP Host dialog box, and closes the Communication Setup dialog box.  

Connect 
The Connect button is enabled only if there is no active FTP connection. This Connect button has two 
functions: 

1. When you select a host profile from the list, clicking this button starts the connection process. 

2. When you add a new host profile, clicking this button adds the new profile to the list and also 
starts the connection process. 
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Cancel 
The Cancel button discards any entries you have made on any of the three tabs and closes the 
Communication Setup dialog box.  

Help 
The Help button displays this help screen. 

  

Settings Tab 

The Settings tab is one of the tabs in the Communication Setup property sheet. 

Email Address 
The email address entered here is automatically entered as the password for any anonymous entries 
into a host. For this reason, the connection could fail if this field is left blank. For more information on 
the anonymous setting, see Profiles Tab.  

Folder for Temporary Files 
This is the directory on the local PC hard drive that is used by the PASSPORT FTP client to store 
temporary files, such as the files that are created when the remote host lists directory results or when 
you view a file that is located on the remote host computer. The default directory is the Windows temp 
directory. The Browse… button can be used to locate another directory to be used.  

Default Viewer 
This is the Windows program that is used to view a file, whenever there is no program associated with 
the file extension being viewed. By default notepad.exe is used. 

Text File Extensions for Auto-Mode (FTP and FTPS only) 
Determines what file extensions to use for ASCII text transfers when Auto transfer mode is selected. 
Files transferred with extensions listed here will be transferred as text files and all others will be 
transferred as binary. Extensions should be separated with a semi-colon. By default the following 
extensions are listed: .txt;.asp;.ini;.htm;.html;.xml. 

Low Level Trace 
When this option is enabled, the PASSPORT FTP Client writes communication information to a disk file 
while performing FTP file transfer and other functions. You must exit the FTP Client in order for the trace 
file to be completely written to disk. The file FTPTRACE.LOG contains the low level trace information. 
This file is located in the My Documents/Zephyr/Traces folder. This feature is used in trouble shooting 
advanced file transfer problems. This option may only be enabled/disabled from a disconnected session. 

Enable Keep Alive 
This option causes the PASSPORT FTP Client to transmit messages to the FTP server at various time 
intervals to keep the connection alive. If this option is not enabled, some FTP servers will terminate the 
connection if there is no activity between the server and client after a certain time interval.  

Timer value (min) 
This value, specified in minutes, is used in conjunction with the Enable Keep Alive feature. This value 
determines the time interval used when sending keep alive messages to the FTP server. This value must 
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be less than the time out value set on the FTP server in order for the keep alive mechanism to function 
properly.  

Verify Before Replacing or Overwriting a File 
When this option is enabled, a dialog box is displayed with a warning message whenever files are about 
to be overwritten. 

Preserve Date/Time for Downloaded Files 
When this option is enabled, files transferred from the host to the local PC will retain their original 
modified date and time. If time information is not available, a time stamp of 12:00am will be used. If 
disabled, the file will be created on the PC with the current date and time. 

Display Negative Reply from Host in a Dialog Box 
When this option is enabled, a dialog box is displayed with information whenever a file transfer failure 
occurs. These type of errors generally occur when files are being transferred to a host.  

Save Window Size and Position 
When this option is enabled, the window size and position of the PASSPORT FTP Client is saved in the 
current configuration file. The next time the PASSPORT FTP Client is started the window size and 
position are restored. 

Close File Transfer Status Dialog On Completion 
When this option is selected, the File Transfer Status dialog box closes itself when a download is 
completed. If unselected, the File Transfer Status dialog box remains and the user must choose the 
Finish button to return to the PASSPORT FTP Client window. 

Automatically Save Settings without Prompt on Exit 
When this option is enabled, changes to FTP settings will automatically be saved when exiting PASSPORT 
FTP Client. The user will not receive a prompt asking them if they wish to save their changes. 

OK 
The OK button is available only if you opened the Communication Setup dialog box using the 
Communication>Setup menu command. Clicking this button saves the host profile information you have 
entered, adds the profile to the list using the name you have entered in the Profile Name field of the 
Add FTP Host dialog box, and closes the Communication Setup dialog box.  

Connect 
The Connect button is enabled only if there is no active FTP connection. This Connect button has two 
functions: 

1. When you select a host profile from the list, clicking this button starts the connection process. 

2. When you add a new host profile, clicking this button adds the new profile to the list and also 
starts the connection process.  

Cancel 
The Cancel button discards any entries you have made on any of the three tabs and closes the 
Communication Setup dialog box.  

Help 
The Help button displays this help screen. 
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SSH Tab 

The SSH tab is one of the tabs in the Communication Setup property sheet. This tab enables you to 
configure a connection to an Secure Shell (SSH) enabled FTP server. In order to use the PASSPORT SSH 
feature, you must connect to a host system that supports the SSH Secure Shell protocol. Secure Shell 
provided by PASSPORT is based on the PuTTY  implementation of SSH for Win32. 

Protocol Options 

Preferred Protocol 
Specifies which version of the SSH protocol PASSPORT uses when it establishes a connection to the FTP 
server. Two versions are available: SSH-1 and SSH-2. SSH-2 is a newer, more secure implementation and 
is the default setting.  With this setting PASSPORT will first attempt to connect using SSH-2 and will try 
SSH-1 if the server does not support SSH-2. Selecting SSH-2 Only or SSH-1 Only will force the connection 
to this version of the protocol. 

Enable Compression 
This enables data compression for the SSH connection. With this option enabled, data sent by the server 
is compressed before sending, and decompressed at the client end. Likewise, data sent by PASSPORT to 
the server is compressed first and the server decompresses it at the other end. This can help with low-
bandwidth connections. 

Authentication 

Private Key File for Authentication 
Enter the path to the private key file, or locate it using the Browse button. 

SSL Tab 

The SSL tab is one of the tabs in the Communication Setup property sheet.  Using FTPS, sessions are 
protected from eavesdropping, tampering, or message forgery over TCP/IP. PASSPORT FTP implements 
FTPS according to IETF RFC 4217: Securing FTP with TLS. The PASSPORT FTP Client connects to the FTP 
server and begins an unencrypted FTP session as it normally would, then requests that SSL security be 
used through the AUTH TLS command, and performs the necessary SSL handshake. 

Accept Self-Signed Certificates 
Enable to accept a self-signed server certificate. 

Accept Expired Certificates 
Enable to accept a server certificate that has expired. 

Accept Not Yet Valid Certificates 
Enable to accept a server certificate that has a starting date in the future. 

Accept Invalid Certificates 
Enable to accept if the server certificate is invalid for any reason other than the date or signature. With 
this option enabled, the server certificate check will be ignored. 

Select Action to Take if Certificate Not Accepted 
This option determines how PASSPORT will respond to any items above that are unchecked. The items 
above that are checked will ignore this option and allow the certificate. 
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Choose one of the following: 

• Ignore Warning and Connect 

• Prompt for User Action 

• Do Not Connect 

Enable Client Authentication 
Enable to accept client certificates and select the client certificate to be used from the drop down. 

Encrypt Data Channel 
Enable encryption of the data channel. The security standard for FTP states that the data channel 
remains insecure by default. This means that SSL encryption would usually only be enabled on the 
command channel. Although this would protect from eavesdropping of user names, passwords and file 
locations, the uploaded and downloaded files would remain vulnerable. By setting the data channel to 
be encrypted, PASSPORT does not have to implicitly state encryption of the data channel. 

Setting the Available Encryption Protocols 
To enable or limit the available encryption protocols, you can edit the Passport FTP profile as follows:  

In the [Connection] section of Passport FTP client .zfc file or [FTP Server] section of Passport .zws file, 
add following line: 

SSLEnabledProtocols=xxx 

Where xxx can be any combination of following: 

SSL 3 Client/Server: 48 
TLS 1.0 Client/Server: 192 
TLS 1.1 Client/Server: 768 
TLS 1.2 Client/Server: 3072 

For example, if you want to support all of above it will be: 

SSLEnabledProtocols=4032 

This will support TLS1.0, 1.1 and 1.2 (192+768+3072=4032) 

  

Communication > Connect 
The Communication > Connect menu command displays the Communication Setup dialog box, allowing 
you to add or remove host profiles available for an FTP session, or connect to an existing host. This 
command is unavailable when a session is already connected. However, if you create a new window 
(File>New>Window), the Communication>Connect command is available for that new session. 

The Communication > Connect command function can be duplicated by the following: 

• toolbar button 
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• Alt + C, C key sequence 

  

Communication > Disconnect 
The Communication > Disconnect menu command causes FTP to disconnect and terminate the current 
session with the host computer. This command is available only when you are connected to a host in the 
current FTP window. 

The Communication > Disconnect command function can be duplicated by the following: 

• toolbar button 

• Alt + C, D key sequence 

  

Communication > Cancel 
The Communication > Cancel menu command causes FTP to cancel the pending command. This 
command will terminate the current file transfer, whether you are receiving or sending, or it can 
terminate the connection when PASSPORT is in the process of logging into the remote computer. 

Note: If this command terminates the transfer midstream, the portion of the file already transferred 
remains in the receiving directory. 

The Communication > Cancel command function can be duplicated by the following: 

• toolbar button 

• Alt + C, A key sequence 

  

Communication > Quote 
The Communication > Quote menu command opens the Quote dialog box for entering an FTP 
command to send directly to the remote server. Click the OK button to accept the entry or click the 
Cancel button to cancel the entry. 

The Communication > Quote command function can be duplicated by the following: 

• Alt + C, Q key sequence when you are connected to a host 

• F6 short cut key 

How to use the Quote command: 

1. Select Communication > Quote, a Quote dialog box will pop up. 
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2. Type the FTP command as follows: Command <sp> argument. The <sp> means space, and the 
argument may or not be needed depending on which FTP command is used. 

3. Press the OK button. 

Valid FTP commands that can be used: 

CD - CHANGE DIRECTORY  

CWD - CHANGE WORKING DIRECTORY 
This command allows the user to work with a different directory or file storage or retrieval without 
altering his login or accounting information. Transfer parameters are similarly unchanged. The argument 
is a path name specifying a directory or other system dependent file group designator.  

CDUP - CHANGE TO PARENT DIRECTORY 
There are no arguments required. 

GET - GET FILE 
This command gets a host file from the remote host and transfers it to the PC. The only required 
parameter is the remote host file name. The complete syntax follows with the optional parameters in 
brackets. 

GET [host-directory]host-filename [local-directory][local-filename]  

HELP - HELP 
This command causes the server to send helpful information regarding its implementation status over 
the control connection to the user. The command may take an argument (e.g., any command name) and 
return more specific information as a response. The server may use this reply to specify site-dependent 
parameters, e.g., in response to HELP SITE.  

LS - LIST FILES 
The argument is optional. You may specify a directory name. If the argument is not supplied the current 
directory is used.  

NOOP - NO OPERATION 
This command does not affect any parameters or previously entered commands. It specifies no action 
other than that the server sends an OK reply. There are no arguments required.  

PUT - PUT FILE 
This command puts a local PC file to the remote host by sending it to the remote host. The only required 
parameter is the local PC file name. The complete syntax follows with the optional parameters in 
brackets. 

PUT [local-directory]local-filename [[host-directory]host-filename]  

QUIT - LOGOUT OF FTP SESSION 
There are no arguments required.  

SITE - SITE PARAMETERS 
This command is used by the server to provide services specific to the system that are essential to file 
transfer but not sufficiently universal to be included as commands in the protocol. The nature of these 



PASSPORT FTP User's Guide 

26 

services and the specification of their syntax can be stated in a reply to the HELP SITE command. 
Arguments depend on operating system.  

SYST - SYSTEM 
This command is used to find out the type of operating system at the server. There are no arguments 
required.  

TYPE - REPRESENTATION TYPE 
The argument specifies the representation type for transferring files. 

A - ASCII 

I - IMAGE (Binary)  

Examples: 

The following are some examples of Quote commands that you can use to do a file transfer from your 
PC to an MVS mainframe: 

• SITE LRECL=80 BLKSIZE=3120 RECFM=FB 

• SITE PRI=200 SEC=200 TRACKS 

• CWD pub 

• SYST 

  

Communication > Connection Log 
The Communication > Connection Log menu command opens the Pass FTP Log in a Notepad window. 
This log provides information about the host to which you are connected. 

The Communication > Connection Log command function can be duplicated by the following: 

• Alt + C, C key sequence when you are connected to a host 

  

Transfer 

Transfer > Send 
The Transfer > Send menu command begins the process of transferring the selected local folders or files 
to a selected location on the host computer. While the transfer is in progress, the File Transfer Status − 
Sending dialog box appears to keep you updated. 

The Transfer > Send command function can be duplicated by the following: 

• toolbar button 
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• Alt + T, S key sequence 

• F8 short cut key 

Note: the last four file transfers are maintained in a list on the Transfer menu. This is handy for 
frequently used file transfers. 

  

Transfer > Receive 
The Transfer > Receive menu command begins the process of transferring the selected host folders or 
files to a selected location on the local computer. While the transfer is in progress, the File Transfer 
Status − Receiving dialog box appears to keep you updated. 

The Transfer > Receive command function can be duplicated by the following: 

• toolbar button 

• Alt + T, R key sequence 

• F7 short cut key 

Note: the last four file transfers are maintained in a list on the Transfer menu. This is handy for 
frequently used file transfers. 

  

Transfer > ASCII 
The Transfer > ASCII menu command allows you to indicate that the files be transferred in ASCII form 
for FTP and FTPS only. Transfers with SFTP using SSH are always binary. 

The Transfer > ASCII command function can be duplicated by the following: 

• toolbar button 

• Alt + T, A key sequence 

  

Transfer > Binary 
The Transfer > Binary menu command allows you to indicate that the files be transferred in binary form. 
Transfers with SFTP using SSH are always binary. 

The Transfer > Binary command function can be duplicated by the following: 

• toolbar button 

• Alt + T, B key sequence 
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Transfer > Auto 
The Transfer > Auto menu command allows the PASSPORT FTP Client to automatically determine the file 
type based on the file extension for FTP and FTPS only. Transfers with SFTP using SSH are always binary. 

The Transfer > Auto command function can be duplicated by the following: 

• toolbar button 

  

Window 

Window > Local Directory 
The Window > Local Directory menu command changes the focus to the local PC directory pane. This is 
the upper left pane of the window. 

This command can also be accessed by: 

• Alt + W, L key sequence 

  

Window > Local File 
The Window > Local File menu command changes the focus to the local PC file pane. This is the upper 
right pane of the window. 

This command can also be accessed by: 

• Alt + W, F key sequence 

  

Window > Host Directory 
The Window > Host Directory menu command changes the focus to the remote host directory pane. 
This is the middle left pane of the window. 

This command function can also be accessed by: 

• Alt + W, H key sequence 

  

Window > Host File 
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The Window > Host File menu command changes the focus to the remote host files pane. This is the 
middle right pane of the window. 

This command function can also be accessed by: 

• Alt + W, S key sequence 

  

Window > Connection Log 
The Window > Connection Log menu command changes the focus to the connection log pane. This is 
the pane at the bottom of the window. 

This command function can also be accessed by: 

• Alt + W, C key sequence 

  

Window > 1st Horizontal Split 
The Window > 1st Horizontal Split menu command positions the cursor on the slitter bar between the 
local PC directory/file panes and the remote host directory/file panes. The cursor can be moved to 
change the size of the panes. 

This command function can also be accessed by: 

• Alt + W, 1 key sequence 

  

Window > 2nd Horizontal Split 
The Window > 2nd Horizontal Split menu command positions the cursor on the slitter bar between the 
remote host directory/file panes and the connection log pane. The cursor can be moved to change the 
size of the panes. 

This command function can also be accessed by: 

• Alt + W, 2 key sequence 

  

Window > Vertical Split 
The Window > Vertical Split menu command positions the cursor on the slitter bar between the 
directory panes and the file panes. The cursor can be moved to change the size of the panes. 

This command function can also be accessed by: 

• Alt + W, V key sequence 
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Help 

Help > Contents and Index 
The Help > Contents and Index menu command displays this FTP help system. The Contents, Index, and 
Search tabs operate the same as with any standard Windows help system. 

The Help > Contents and Index command function can be duplicated by the following: 

• toolbar button 

• Alt + H, H key sequence 

  

Help > Knowledge Base 
The Help > Knowledge Base menu command connects you to the Rocket Software knowledge base. The 
knowledge base contains answers to the most commonly encountered technical issues when using 
Passport products. 

The Help > Knowledge Base command function can be duplicated by the following: 

• Alt + H, B key sequence 

  

Help > About 
The Help > About menu command displays the About Pass FTP window containing information about 
FTP itself, such as version number. 

The Help > About command function can be duplicated by the following: 

• toolbar button 

• Alt + H, A key sequence 

  



 

31 

FTP COM Object 
Methods & Properties 

Close method 
Disconnects and logs out of the FTP server. 

Syntax 

Object.Close 

Parameters 

None 

  

DeleteFile method 
Deletes a file on the FTP server. 

Syntax 

Object.DeleteFile strRemoteFile 

Arguments 

strRemoteFile 

Argument type: String Required 

Specifies the name of the file (or files) to delete 

  

Disconnect method 
Disconnects and logs out of the FTP server. 

Syntax 

Object.Disconnect 

Parameters 

None 
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FileAttributesString property 
Returns the raw data of the file attributes of the FTP server. 

Syntax 

Object.FileAttributesString 

Return data type 

String 

  

FileDate property 
Returns the date of the file. 

Syntax 

Object.FileDate 

Data type 

Date 

  

FileDateString property 
Returns the string of the date, in the date format of the FTP server, of a file. 

Syntax 

Object.FileDateString 

Return data type 

String 

  

FileIsDirectory property 
If the file is a directory, returns true, otherwise returns false. 

Syntax 

Object.FileIsDirectory 
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Return data type 

Boolean 

  

FileName property 
Returns the name of the file. 

Syntax 

Object.FileName 

Returns the name of the file. 

Return data type 

String 

  

FileSize property 
Returns the size of the file. 

Syntax 

Object.FileSize 

Returns the size of the file. 

Property 

Long (read only) 

Return data type 

Long 

  

FileSizeEx property 
Returns the size of the file. If you are working in a development environment that supports 64-bit data 
values, you can use FileSizeEx for file size values that exceed the Long integer maximum (2,147,483,647). 

Syntax 

Object.FileSizeEx 
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Returns the size of the file. 

Property 

UINT64 (read only) 

Return data type 

UINT64 

  

FileSizeString property 
Returns the size of the file. 

Syntax 

Object.FileSizeString 

Returns the size of the file. 

Property 

String (read only) 

Return data type 

String 

  

GetCurrentDirectory method 
Returns the current FTP server directory. 

Syntax 

Value = Object.GetCurrentDirectory() 

Returns the current FTP server directory. 

Property 

String (read only) 

Return data type 

String 
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GetNextFileDetails method 
Continues the current file search operation initiated by OpenDirectoryListing and returns True if 
successful. 

Syntax 

Object.GetNextFileDetails 

Remarks 

You must call GetNextFileDetails at least once before querying any of the following properties: 
FileAttributesString, FileName, FileIsDirectory, FileDate, FileDateString. 

  

LastError property 
Returns an FTP client error value. 

Syntax 

Object.LastError 

Return value type 

Long 

Return value 

Returns the error code. Normally, LastError returns 0 for success or an FTP client error value. 

Here are some common errors (rcFTP_Error = 0x20000000): 

• rcFTP_Error + 0x03: Failed to make a connection 
• rcFTP_Error + 0x04: Open/Create local file error 
• rcFTP_Error + 0x0E: FTP is not connected 
• rcFTP_Error + 0x10: Invalid parameters passed in, such as "Invalid host address", "Invalid 

username or password" 
• rcFTP_Error + 0x18: Socket error, such as "Connection time out" or "Windows sockets 

initialization failed" 
• rcFTP_Error + 0x15: Cannot get file attribute 
• rcFTP_Error + 0x1E: Cannot find file 

  

LastErrorString property 
Returns the error description for the last error. 
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Syntax 

Object.LastErrorString 

Return value type: 

String 

Remarks 

See common errors listed in the LastError property. 

  

Open method 
Establishes the connection to an FTP host. 

Syntax 

Object.Open SiteAddress, UserName, Password [,Account] [,ServerPort] 
[,PassiveMode] 

Arguments 

SiteAddress 

Argument type: String. Required 

Specifies the address of the FTP site, either an Internet address or name. 

UserName 

Argument type: String, Required 

Specifies the user name for initiating the server login. 

Password 

Argument type: String, Required 

Specifies the password assigned to user UserName. Default is AnonymousPassword. 

Account 

Argument type: String, Optional 

Specifies an account that user UserName has rights to access. Default is blank. 

ServerPort 

Argument type: Integer, Optional 
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Specifies a nonstandard TCP service port number or socket for FTP. If ServerPort is not specified, 
the standard FTP service port (21) is used. 

PassiveMode 

Argument Type: Boolean, Optional 

Specifies whether the client should establish a passive data connection to the FTP server. Default is 
False. 

  

OpenDirectoryListing method 
OpenDirectoryListing 

Starts a directory listing in the current directory on the FTP server. 

Syntax 

Object.OpenDirectoryListing [strRemoteFileFilter] 

Starts a directory listing in the current directory on the FTP server. 

Arguments 

strRemoteFileFilter 

Argument type: String, Optional. Default is an empty string (""), that is, to list files in the current 
directory. 

This string can contain remote host wildcard characters 

  

ReceiveFile method 
Transfers one or more files from the FTP server to a local PC. 

Syntax 

Object.ReceiveFile strLocalFile, strRemoteFile [, type] [, disp] 

Arguments 

strLocalFile 

Argument type: String, Required 

Specifies a local file. This string can be empty or can contain just drive and path information, in 
which case the FTP server file name is used to generate a local file. This string cannot contain 
wildcard characters. 
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strRemoteFile 

Argument type: String, Required 

Specifies an FTP server file. This string can contain wildcard characters (to transfer multiple files). 
The wildcard characters must be appropriate for the FTP server. 

Note: If you are connected to a VMS host, fully qualified path names are not supported. For these 
hosts, use SetCurrentDirectory to specify a server location. 

type 

Argument type: Enumeration, Optional 

Specifies what type of file is being transferred. The possible values are rcAscii (0), rcBinary (1), and 
rcSmart (3). 

disp 

Argument type: Enumeration, Optional 

Specifies what to do if the received file already exists on the PC. The possible values are rcOverwrite (1), 
rcAppend (2), default is rcOverwrite 

Remarks 

Files transferred with extensions, .txt;.asp;.ini;.htm;.html;.xml, will be transferred as text (rcAscii) and all 
others will be transferred as binary (rcBinary). 

  

RenameFile method 
RenameFile 

Renames a file on the FTP server.   

Syntax 

Object.RenameFile strRemoteFile, strNewName 

Arguments 

strRemoteFile 

Argument type: String, required 

Specifies the file to be renamed. 

strNewName 

Argument type: String, required 
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Specifies the new name for the file or directory 

  

SendFile method 
SendFile 

Transfers one or more files from a local PC to the FTP server. 

Syntax 

Object.SendFile strLocalFile, strRemoteFile [, type] [, disp] 

Arguments 

strLocalFile 

Argument type: String, Required 

Specifies a local file. This string can contain PC wildcard characters (to transfer multiple files). 

strRemoteFile 

Argument type: String, Required 

Specifies a file on the FTP server. This string cannot contain wildcard characters. If this string is an 
empty string (""), the local file name is used to generate the file name on the FTP server. 

Note: If you are connected to a VMS host, fully qualified path names are not supported. For these 
hosts, use SetCurrentDirectory to specify a host location. 
If the parameter, strLocalFile, contains PC wildcard characters, this parameter should be an 
empty string (""). 

type 

Argument type: Enumeration, Optional 

Specifies what type of file is being transferred. The possible values are rcAscii (0), rcBinary (1), and 
rcSmart (3). 

disp 

Argument type: Enumeration, Optional 

Specifies what to do if the received file already exists on the FTP server. Currently, it is always 
rcOverwrite (=1) 

Remarks 

Files transferred with extensions, .txt;.asp;.ini;.htm;.html;.xml, will be transferred as text (rcAscii) and all 
others will be transferred as binary (rcBinary). 
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SetCurrentDirectory method 
Sets the current server directory. 

Syntax 

Object.SetCurrentDirectory strHostPath 

Arguments 

strHostPath 

Argument type: String, Required 

Specifies the directory on the FTP server. 

OpenDirectoryListing 

Starts a directory listing in the current directory on the FTP server. 

Syntax 

Object.OpenDirectoryListing [strRemoteFileFilter] 

Starts a directory listing in the current directory on the FTP server. 

Arguments 

strRemoteFileFilter 

Argument type: String, Optional. Default is an empty string (""), that is, to list files in the current 
directory. 

Note: This string can contain remote host wildcard characters 

  

SSHPrivateKeyFile property 
Sets the SSH Private Key File for Authentication. 

Syntax 

Object.SSHPrivateKeyFile = Value 

Sets the SSH Private Key File for Authentication. 

Property 

String 
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Return data type 

None 

  

TLSEncryptData property 
TLSEncryptData 

Returns or specifies whether or not data is encrypted when the FTP client is configured to use SSL 
encryption. 

Syntax 

Get: Value = Object.TLSEncryptData 

Set: Object.TLSEncryptData = Value 

Data type 

Boolean, the default value is True. 

Remarks 

If UseTLS is set to False, this property is ignored. 

  

Tracing property 
Enables Tracing. 

Syntax 

Object.Tracing = Value 

Enable Tracing 

Property 

Int 

Return data type 

None 

  

UseSFTP property 
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Returns or specifies whether RocketFTP transfers commands using SFP or not 

Syntax 

Get: Value = Object.UseSFTP 

Set: Object.UseSFTP = Value 

Data type 

Boolean, the default value is False. 

Remarks 

If UseSFTP is True, RocketFTP will connect to a host using the SFTP protocol. Therefore, you have to set 
this property before you call Open function if you want to connect to a SFTP server. 

  

UseTLS property 
Returns or specifies whether RocketFTP transfers commands using TLS  or not 

Syntax 

Get: Value = Object.UseTLS 

Set: Object.UseTLS = Value 

Data type 

Boolean, the default value is False. 

  

Sample VBScript 

FTP COM Object Sample 
The following is a sample VBScript using the Rocket FTPCom Object.  This script will log onto an FTP 
server and report back the number files and directories found. To make it work, you will have to replace 
"127.0.0.1" with the  address of an FTP server that you have an existing logon account, and change the 
"username" and "password" with your credentials. 

Sub Main 

Const ftpASCII = 0  'support FTP_ASCII 
Const ftpBinary = 1 'support FTP_IMAGE 
Const ftpSmart = 3  'support FTP_IMAGE 
Const ftpTenex = 4 
Const ftpAskUser = 0 
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Const ftpOverwrite = 1 
Const ftpAppend = 2 
Const ftpCancel = 4 
Const ftpUpdate = 7 
Const ftpSkip = 8 
Const ftpUnique = 12 

Set Ftp = CreateObject( "RocketFTP.FtpSession" ) 

If (Ftp Is Nothing) Then 

MsgBox "Unable to create Rocket FTPCom Object" 

Else 

MsgBox "You have successfully connected to 
the Rocket FTPCom Object, click OK to 
continue" 

End If 

With Ftp 

.Open "127.0.0.1", "username", "password"  'Change to your FTP 
Server's address and login credentials 

If (.LastError > 0) Then 

MsgBox "Err #: " & Ftp.LastError & vbCr & Ftp.LastErrorString 

Exit Sub 

End If 

' .SetCurrentDirectory "\Home"  'This is used to set the desired 
directory if other than default 
.OpenDirectoryListing "." 

FileCount = 0 
DirCount = 0 

FileInfoStr = "Directory Contains:" & vbCr 

Do While .GetNextFileDetails 

If .FileIsDirectory = False Then 

DirCount = DirCount + 1 

Else 

FileCount = FileCount + 1 

End If 

Loop 
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FileInfoStr = FileInfoStr & "Total Files: " & FileCount & vbCr 
FileInfoStr = FileInfoStr & "Total Directorys: " & DirCount & vbCr 

MsgBox FileInfoStr 

'.ReceiveFile "pc.txt", "host.txt", ftpASCII ''This is 
provided to show the syntax to receive a file 
'.SendFile "pc.txt", "host.txt", ftpASCII     'This is 
provided to show the syntax to send a file 

.Close 

End With 

End Sub 

Main 
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Troubleshooting 
FTP Error Messages 
10065 "Please restart PASSPORT FTP Client for changes to take effect." 

Explanation: You must close PASSPORT FTP client, and restart it for the new language setting to take 
effect. 

    
User 
response: 

1.  Close the PASSPORT FTP client  
    
2.  Restart the PASSPORT FTP client. 

    
10098 "Invalid license code." 

Explanation: The license code you have entered is not valid. 
    
User 
response: 

1.  Locate the passport.key file. This file is located in the install directory. The default 
install directory is C:/Program Files/PASSPORT.  
    
2.  Open the passport.key file in a text editor.     
    
3.  Copy and paste the license code into the file with the following format:       
[Setup] 
Key=XXXX-XXXX-XXXX-XXXX  
where XXXX-XXXX-XXXX-XXXX is the license code provided by Rocket Software  
    
4.  Save and close the passport.key file. 

    
15001 "Maximum of 256 profiles allowed!" 

Explanation: You have reached the maximum number of FTP profiles supported by PASSPORT. 
    
User 
response: 

To create another profile, you will have to delete one that's not in use. 

    
15002 "Profile name already exists. Please type a different profile name." 

Explanation: The profile name that you are trying to add already exists. 
    
User 
response: 

Please use a different profile name. 

    
15003 "Please select a profile first." 

Explanation: You are trying edit or remove a profile before selecting it. 
    
User Select a profile first then click on Edit or Remove. 
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response: 
    
15004 "Invalid profile name" 

Explanation: This error occurs because the profile name field is left blank when adding a profile. 
    
User 
response: 

Please enter a profile name when adding a profile. 

    
15005 "Default port number for SFTP/FTP is normally 22/21. Do you want to change the port 

number to 22/21?" 

Explanation: You will get this warning when switching the server type between FTP (FTPS) and SFTP 
using SSH. 

    
User 
response: 

1.  If your SFTP server port is set to 22 then click YES to change the port number.  If it's not, 
then click NO to change it to your desired port number.  If you're not sure, contact your FTP 
administrator to obtain this information.  
      
2.  If your FTP server port is set to 21 then click YES to change the port number.  If it's not, 
then click NO to change it to your desired port number.  If you're not sure, contact your FTP 
administrator to obtain this information. 

    
15006 "Please add a profile first!" 

Explanation: When you add a new configuration (File > New > Configuration), and then click 
Communication > Connect without adding a profile, this error will occur. 

    
User 
response: 

You will need to add a profile first then select that profile before connecting. 

    
15007 "You should at least provide FTP Host Name and Port." 

Explanation: When you are connecting using a profile that does not contain a host name/IP address or 
connecting through a firewall without its IP address, this error will occur. 

    
User 
response: 

Enter a host name or IP address in the required field. 

    
15008 "Default Viewer can not be empty." 

Explanation: This is the Windows program that is used to view a file, whenever there is no program 
associated with the file extension being viewed. If there are no viewer specified under the 
Communication > Settings tab then this error will occur. 

    
User 
response: 

Specify a Windows program that you want to use to view a file. 
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15009 "There is no certificate available in your system store." 

Explanation: There is no certificate available in your Windows certificate store to be used for the SSL 
client authentication. 

User 
response: 

1.  Ensure that your host system is configured for SSL client authentication.       
    
2.  If SSL client authentication is required, you must import your personal certificate to the 
Windows certificate store before PASSPORT can use it:  
    
   a. In Internet Explorer, click Tools > Internet Options.  
   b. In the Content tab, click Certificates.  
   c. Select Client Authentication as the Intended Purpose.  
   d. Click Import. The Import Wizard will prompt you for the location of your client 
certificate.  
    
3.  Select the store where you want the certificate to be placed. It is recommended that you 
select the option to allow Internet Explorer to Automatically Select the Appropriate Store 
Based on the Certificate Type unless you have been instructed otherwise.  
    
4.  Click Finish.  
    
5.  Close Internet Explorer.  
    
6.  Restart PASSPORT FTP, and select the certificate from 'My Store'. 

    
15010 "<FileorFolderName> already exists on the <PCorHost>. Do you want to <SendorReceive> 

and replace it?" 

Explanation: File (folder) already exist on local PC or host, do you want to send or receive? 
    
User 
response: 

1.  Click YES/YES TO ALL if you want to proceed and NO or  
      
2.  Click CANCEL if you want to abort the operation. 

    
15011 "Transfer failed: <FailureReason>" 

Explanation: Transfer failed because of various reasons.  In this example, the file being transferred to the 
host does not have the MVS dataset name format. 

    
User 
response: 

Correct the error before performing the next transfer.  In this example, rename the file to 
use the MVS Dsname convention before doing your transfer.  Refer to your IBM FTP server 
for the correct format to use. 

    
15012 "Can't save to <Path>. Do you want to continue exiting?" 

Explanation: Cannot save the FTP profile before exiting. 
    
User 
response: 

Ensure that you have the necessary permission to save and the FTP profile is not set to read 
only. 
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15013 "Error reply from server: <Error>" 

Explanation: These are error messages being returned from the FTP(S) server due to misconfiguration or 
conditions that are not being handled by the server. 

    
User 
response: 

1.  An example is error 550: '550 Directory not empty'. You will receive 
this error when attempting to delete a directory that contains files if the 
FTP server you are connecting to is configured to only allow deletion of 
empty directories.  
      
2.  For solutions to other errors, contact your FTP server administrator or 
refer to your FTP server documentation. 

    
15014 "Error code(<ErrorCode>): Unable to run <ProgramName>" 

Explanation: Cannot run the program. 
    
User 
response: 

Ensure that the program is installed and properly configured on your local PC. 

    
15015 "<FileorFolderName> already exists on the directory: <Directory>. Would you like to 

replace the existing one?" 

Explanation: When you copy/paste a file/folder that already exists locally, you will get this confirmation 
warning. 

    
User 
response: 

Click YES/YES TO ALL if you want to proceed and NO or CANCEL if you want to abort the 
operation. 

    
15016 "Please select file(s) first." 

Explanation: When no local file(s) are selected before performing SEND or no host file(s) are selected 
before performing RECEIVE, this error will occur. 

    
User 
response: 

Select a local file(s) before sending or a host file(s) before receiving. 

    
15017 "Select only one local folder or file first." 

Explanation: When multiple local/host folder(s) or file(s) are selected before performing RENAME, this 
error will occur. 

    
User 
response: 

Select one local/host folder or file to be renamed at a time only. 

    
15018 "Please select local folder(s)/file(s) first" 

Explanation: When no local folder(s) or file(s) are selected before performing DELETE, this error will 
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occur. 
    
User 
response: 

Select a local folder(s) or file(s) before deleting. 

    
15019 "Are you sure you want to delete these <Number> items?" 

Explanation: This is a warning that you will be deleting these number of items. 
    
User 
response: 

Click YES if you want to proceed and NO you want to abort the operation. 

    
15020 "Are you sure you want to delete the folder <Name> and all its contents?" 

Explanation: This is a warning that you will be deleting a folder and all of its contents 
    
User 
response: 

Click YES if you want to proceed and NO you want to abort the operation. 

    
15021 "Are you sure you want to delete <FileName>?" 

Explanation: This is a warning that you will be deleting this particular file. 
    
User 
response: 

Click YES if you want to proceed and NO you want to abort the operation. 

    
15024 "The File: <FileName> is not a valid PASSPORT FTP configuration file. Please rename this 

file and then start." 

Explanation: This error will occur when the PASSPORT FTP configuration file is not in a valid format. 
    
User 
response: 

1.  Close the PASSPORT FTP Client.  
      
2.  Locate the file named passport.zft on your system. This file will be located in the 
User directory that was designated at the time of install. The default user directory is:  
My Documents\Passport\Product Name.  
    
3.  Rename or delete the passport.zft file.  
      
4.  Restart the PASSPORT FTP Client. 

    
15025 "Unable to find 'Passport.key'" 

Explanation: PASSPORT FTP cannot locate the Passport.key file, which contains the license code for 
the product. 

    
User 
response: 

1.  Ensure that the Passport.key file is available in the program directory. The default 
program directory is C:/Program Files/PASSPORT.  
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2.  If the Passport.key file cannot be located, reinstall PASSPORT using the license code 
provided to you from Rocket Software. 

    
15026 "Current FTP connection will be terminated to open <ProfileName> configuration. Do you 

want to continue?" 

Explanation: This warning will occur if you are trying to open FTP configuration while still connecting 
through your existing FTP connection. 

    
User 
response: 

Click YES if you want to proceed and NO you want to abort the operation. 

    
 15027 "Failed to create folder <FolderName>" 

Explanation: Failed to create folder on SFTP server because you do not have permission. 
    
User 
response: 

Ensure that you have the necessary permission to create folders. 

    
15028 "Failed to delete following folder: <FolderName>" 

Explanation: Failed to delete folder on SFTP server because its not empty or you do not have permission. 
    
User 
response: 

Ensure that the folder is emptied and you have the necessary permission to delete folders. 

    
15029 "Please select a local folder first" 

Explanation: When you are trying to transfer a file or a folder from the host without specifying a 
destination on the local PC, this error will occur. 

    
User 
response: 

Specify a destination on the local PC before performing the transfer. 
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